Slow Mac after OS X Yosemite Update? Fear not !

When I installed OS X Yosemite, my first impressions were : “WOW”, “Amazing”. But two after the installation, my MacBook started to get slow. There was heavy Ram usage. Oh, I almost forgot. Just after the installation, web pages in Safari were loading so slow. Since so many people are having these issues with the new operating system released by Apple, I thought of sharing the methods that I used to get them resolved.

Apple MacBook Pro running OS X Yosemite [1]
Apple MacBook Pro running OS X Yosemite [1]
Solution for slow loading of web pages in Safari

  1. Go to Macintosh HD in Finder and open Library.
  2. Open “Launch Agents” and “Launch Daemons” (one at a time).
  3. See whether there is anything related to “Parallels”. If there are any “Parallels” files, move them to Trash.
  4. Empty the trash.

Voila ! Safari is now fast, eh?

Alright. The next was the most painful thing. Slow computer…OMG !! There was heavy RAM usage in the Activity Monitor. Three processes, namely “coreaudiod”, “identityservicesd” and “callservicesd” were not responding. I contacted Apple Support and they asked me to do a Disk Repair and Permissions Repair but the problem persisted. Then they asked me to do a clean install. Well, this was frustrating since I did not have a backup of my hard drive. I did not give up. Googled the issue and found out so many people are having the issue.

Luckily, I found out that in Audio Midi Setup under Utilities, there was a Digi CoreAudio device which I had no clue from where it got there. This problem can arise if you had Pro Tools installed in your Mac.

Audio MIDI Setup in Mac OS [2]
Solution for heavy RAM usage and non-responding services

  1. Find Digidesign CoreAudio.plugin in the following path : /Library/Audio/Plug-Ins/HAL
  2. Delete the plug-in and remove it from the trash.
  3. Reboot the system.

My laptop was fast after taking these steps. Goodbye “Not responding” processes ! This also solved the issue where the dock remains when I shut down my Mac, which terminates the shut down process and I had to force shut down.

N.B. There might be an audio device with a different name, in which case, you need to remove the plug-in associated with it. However, the path for finding it will be the same.

I hope this post helps for the people waiting to get these issues solved.

References

[1] MacBook Pro running OS X Yosemite. 2014. [ONLINE] Available at: http://1.design-milk.com/images/2014/06/osx_design_spotlight_your_files1.jpg. [Accessed 11 November 2014].

[2] Audio MIDI Setup in Mac OS. 2014. [ONLINE] Available at: https://cdn.tutsplus.com/audio/uploads/legacy/qt_089_multiple/image01.png. [Accessed 05 November 2014].